Classic Heartbeat Forums

Classic Heartbeat Forums (http://www.classicheartbeat.com/forums/index.php)
-   67-72 Chevy/GMC Suburban & Panel Message Board (http://www.classicheartbeat.com/forums/forumdisplay.php?f=23)
-   -   Neg. Battery post very hot (http://www.classicheartbeat.com/forums/showthread.php?t=5723)

mjgord51 11-27-2016 06:31 PM

Neg. Battery post very hot
 
While my cousins truck sits waiting for more parts I start it now in then & run it for a while to keep the battery up. All that was fine up in till today when I tried to start it up and ran the battery down. I went to take the battery out to charge it and the Neg. post was so hot it melted the quick disconnect knob on the neg. post. I have never had this ever happen to me ever and I am a little stumped right now. When I owned it it went through a number of wiring & ground problems and eventually all was fixed & was starting right up ok. I know I probably left out some details so ask me what ever you think I need to tell you to fill in what I have left out. His truck is a 68 C10 not with the original engine, trans, alt & dist for the year of truck but that's not anything new for today's builds. Thanks for any help, all would be appreciated. Marvin

Up Date. problem solved. I guess I forgot to tighten the - post quick disconnect knob OPS.

mjgord51 11-27-2016 07:37 PM

I am Sorry this thread needs to be moved to the right spot: 67-72 Chevy/GMC Trucks Message Board. I'll ask Wes to move it tomorrow.


All times are GMT -6. The time now is 05:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2003 - 2008, Classic Heartbeat